Do we really need the Ruby scripting support?

With version 0.8, newsbeuter introduced Ruby scripting support, although still undocumented and not really in a usable state. So, the next major release is coming up, and one thing in my head is whether we really need Ruby support in newsbeuter. So far, I couldn’t find any use case where Ruby support would be useful. So the question is: should the Ruby support remain, or should it be removed again? I strongly urge for your thoughts and comments, if nobody presents me a clear case why we would need Ruby support in newsbeuter, I think I will remove it again.

2 Responses to Do we really need the Ruby scripting support?

  1. shean says:

    while i think it is a really cool feature to come up i miss a real usecase as well.

  2. Lance says:

    Wouldn’t scripting be useful for those that want to exend newbeuter?

    For example, what if someone wanted to add functionality that would let them automatically bookmark items of interest to their delicious account?

    Would doing this through scripting support be the way to go?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: